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1. Requirements

Below are the items required for setting up and testing the Modbus TCP converter.

Part No. Description Qty Comments
10051-CCC Modbus TCP Converter 1
10066-CCC Ethernet Crossover cable 1 Part of 10051-CCC
12VDC Adapter 1 Part of 10051-CCC
Computer 1 Any computer with Win OS (Win XP

or higher)

2. Download device driver software

Below is the link to download the device driver for Modbus TCP Converter.

http://www.cccusi.com/Images/custDownloads/setup di x86x64cd 4.3.0.9.zip
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3. Install device driver software

3.1 This section assumes that device driver software was downloaded on the computer.

3.2 Unzip the driver, open the folder, and then double click “setup_di_x86x64cd_4.3.0.9.exe” to follow the
onscreen instructions to install the driver.

3.3 If Microsoft .Net Framework (as shown in Fig 3.3.1) is not installed, install the Framework first. Otherwise
click “Install” to install the “Devicelnstaller 4.3.0.9”.

In order to install Devicelnstaller you must first install these
companents:

Microsoft .\MET Framework 4.0 (x86 x64) (Installed)
DeviceInstaller 4.3.0.9 (x64) English

o

Windows & (x64)

Fig3.3.1
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3.4 Infig 3.4.1, click “Next” to proceed.

iz =

Welcome to the Lantronix Devicelnstaller 4.3.0.9 [l
(x64) Setup Wizard = e

The installer will guide yau thraugh the steps required to nstall Lantranis Devicelnstaller 4.3.0.9 [+464]
on your computer,

WARNING: This computer program is protected by copright law and international reaties
Unautherized duplication or distribution of this program, or any portion of t, may result in ssvere aivil
or ciiminal penalties, and will be prosecuted to the marimum extent possible under the law

Fig3.4.1

3.5 Infig 3.5.1, click “Next” to accept the default directory.

10051-CCC Setup Procedure

o
L x

Select Installation Folder .l

The installer will install Lantioniz Devicelnstaller 4.3.0.9 [#64) to the following folder.

Tainztall in this folder, click “Next. Tainstall to a difterent folder, enter it below or click *Browse"

Folder

C:%Program Files\Lantronix\Devicelnstallerd. 3%

Browse..

Cancel | | <Back | [ Hest>

Fig 3.5.1
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3.6 Infig 3.6.1, click “Next” to proceed.

iz,

Confirm Installation

==

=

The installer i ready to install Lantianis Dievicelnstaller 4.3.0.9 (+64) on pour computer

Click "Mext" to start the installation.

3.7 Ificon is not created on desktop, go to the directory "C:\Program Files\Lantronix\Devicelnstaller4.3\” to

create a shortcut.
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4. Hardware Connections

Suggested hardware connection is shown below.

Device

RS485
Port

A(+)
B()

Half Duplex

A+
B(-)

RS485
Port

Terminating Resistors
not required

Power Input

RJ 45 Crossover cable

GND

9~24VDC

Modbus TCP Eth
Port
Converter 2
With Surge Protection RJ 45
Model No: 10051-CCC
Serial No:
Tested on:
e = e ®
Controls Communications PWR

Consultants LLC

Grayslake, llinois 60030, U.S.A.
m (P) +1.312.718.3368

e\
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5. Configure Modbus TCP Converter

5.1 Once the software is installed, double click the icon “Devicelnstaller” (as shown in Fig 5.1.1) to start the

software.

5.2 Infig 5.2.1, once the software started, select “Do not prompt me about this”. Then click “No”.

Wwould you like to check for updates to the Product Information Base?
(An Internet connection is nesded for updates)

The Product Information Base has not been updated since installation.

Do not prompt me about this.  (Can enable this again from Tools->Cptions)

Yes No
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5.3 Be sure to set up static IP address of computer by using the instructions shown in Section A.
5.4 In File menu, click “Tool>Option” (as shown in Fig 5.4.1) to open the “Option” page.

Cr=,

Fig5.4.1

5.5 In the “Network” tab of “Option” page (as shown in Fig 5.5.1), select “Ethernet”. Then Click “Apply” and
then click “Ok” to exit the page.

[ Hetrark || Customization
Use theFollowing network adapter:
Tame 1 addvess Subnet mask:
W 1681 5,285
(7 Emernet WIIALW0 2952552640
o Cancel Ao
Fig 5.5.1
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5.6 If the Modbus TCP Converter is connected according to session 4, then the software will display the
found IP address of converter in less than a minute. Note that if the computer’s IP does not match with
converter’s IP, the software will display “unreachable” status.

Eile Edit VMiew Device Tools Help
pSEar(h eExcludE ‘BAssignlp

8 Name User Name User Group IP Address Hardware ﬂddreN Status
gl Ethemet (1.1.1.100) -
S emet | ! 2 Unknown(YM) 169.254.127.86 00-80-A3-92-99-B9 Unreachable

& Unknown

ﬁ Ready

Fig 5.6.1

5.7 If the converter is not display, then in File menu, click “Device>Search” (as shown in Fig 5.7.1) to search
for the Modbus TCP Converter.

Ereite Devics Form Sesreh Resuts.

Fig5.7.1
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5.8 Using the procedure in session A, change the first 3 fields of computer’s IP and default gateway to match

with the Modbus TCP Converter so that the computer can communicate with it. Note: Leave Subnet

Mask as “255.255.255.0”.

For example:

Before change:

IP address -

Internet Protocol Version 4 (TCP/IPvd) Properties 2

1% Field 2" field

3" field

4" field

1 . 1

1

100

Default gateway -

General

You can get P settings assigned automaticaly if your netwiork supports
this capabiity. Otherwise, you need to ask your network administrator

TP address: 11,1 .10
Subnetmask: 255 . 255 . 255 . 0
Default gateway: 1111

Obtain DS server address automatically

@ Use the following DS server addresses:

1% Field 2" field

3" field

4" field

1 . 1

1

[ validate settings upon exit ez

o

After change:

IP address -

Intemet Protocol Version 4 (TCP/IPvA) Properties ?

1* Field 2" field

3" field

4" field

169 . 254

127

100

Default gateway -

1° Field 2" field

3" field

4" field

169 . 254

127

1

10051-CCC Setup Procedure AN 10051_1 (rev A)

General
You can get P settings assined automatically if your network supports

this capabilty. Othervise, you ned to ask your network administrator
h g

(O@btainan [P addess automatically
@ (e Hhe Folaiiing 17 sacress

1P address: 169,254, 127 . 100
Subret mask: 255 . 255. 255 . 0
Default gatenay: 169 .254. 177 1

Obtain DNS server address automatically

@ Use the folowing DNS server addresses:
Alternate DNS server:

[] valdate settings upon exit el
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5.9 Once step 5.8 is done, exit the software and then restart again. In a few seconds, the software will
display the device being online. See fig 5.9.1.

File Edit View Device Tools Help
pSEarch eﬁ(c\uda ‘LAssignIP

E‘"% Lantronix Devices - 1 device(s) Name User Name User Group IP Address Hardware Address Status

- Ethemet (169.254.127.100) .
£ Unknown 2 Unknown (M) 169.254.127.86 00-80-A3-52-99-B3 Orline
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6. Configure serial communication settings

This session shows the steps to configure the Modbus TCP converter so that serial communication settings

match with the slave device.

6.1 In the “Devicelnstaller” software, expand the cross (in the left pane) as shown in Fig 6.1.1.

fie  fdi Yiew Dedce Inoks el
i Do el
\ 2 C3 o

G
Comerts

D Py ks

Tioe [
w ™

Foream Adsms [T
Pz 2
[ 230
Criee Satn Crine
Whibe  izsam =
1P e e Ctnarad Sy

St e a0
Gty

1682841271

6.2 In Fig 6.2.1.Click “Telnet Configuration” tab, then click “Connect”.

File Edit View Device Tools Help
’:.)Search a&:lude ‘;Asslgan eUpgrade

= % Lantronix Devices - 1 devicels)

\
Device Detais | Web Configuration || Teinef Configuration |

E-gig Ethemet (169.254127.100)
23 Unknown

IP Address: 169.234.127.86 Port: 9999

‘;Connect & Clear

g Unknown(YM) - firmware v2.3.0.1GC
- 169.254.127 86

10051-CCC Setup Procedure AN 10051 _1 (rev A)
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6.3 As shown in fig 6.3.1, press the enter key.

File Edit View Device Tools Help

) Search  igrExclude W& Assign P &3 Upgrade

-8l Lantronix Devices - 1 device(s)
gl Ethemet (169.254.127.100)
=23 Unknown
B4 Unknown(YM) -fmware v3.3.0.1GC
L5 169.254.127 86

Device Detals | Web Configuration | Telnet Cortiguration |

IP Address: 160.254.127.86 Port: 9999 %Cm\ned

& Clear

Fig 6.3.1

6.4 As shown in fig 6.4.1, enter ‘2’ to select “Serial & Mode Settings”.

Be B Yeu Qee Jook Hep
Psech Dt @ Asion® @ upgade
5l Lrbores Doves -1 dovcot)

Devce Detsts | Web Corfipuron | Teost Corfgurston

= g Brere
=3 Wknown.

EM

127100

5 Unknonn(YM) e ¥330 1GC.
AT

P Address 16825012795 Pot 9% &) Disconnect ¢ Clear

[Wodbus/TCP to RTU Bridge
YAC address 00803929989
Sottvare version V3.3.0.16C (131237) XPTEXE

Fress Encer for Setup Mode
Mode1: Device Server Fluse! (Firmware Code:nd)

Modbus/TCP o RTU Sridge Setup

1) Hetwork/IE Sectinga:

169.284.227. 86
169.284,127.1
285.285.288.0

rotocol ...

Serial Interface ....

3) Moden/Configurable Pin Settings:

ce1 485 Output Enable
GPIO (In)

Modbus/RTU, Slave () attached
. 9600,8,N,1,R3485.

D) efault sectings, S)ave, Q)uit without save
Select Command or paramerer set (1..5) to change:

10051-CCC Setup Procedure
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6.5 As shown in fig 6.5.1, enter ‘1’ to select “Slave” device.

Gl Ede Yuw Deace Jooh e

< 1h S ¥330.16C
e

EM

| Device Detots | Vish Corfigurntion Toot Corfiprstion

P hddress 16925412786 Po 99 @ Duconneat ¢ Clear

[Modbas/TCh to RTU Bxidge
JAC address 0080A3929989

Software version ¥3.3.0.16C (131217) XFTEXE
Press Zacex for Secup Mode

Model: Device Server Pluse! (Firmware Coderi)

Modnas/xcs o xT0

Djezaulc seccings, S)ave, Qyuit wichout save
se1ect Command or parameter ser (1..5) o change:

ccached Device (1=Siave ZeMaster) (1) 7

6.6 As shown in fig 6.6.1, enter ‘1’ to select “Modbus/RTU” protocol.

e Ede Yew Dence Jook Hep
| sexrch D bachude & AszgnlP @ Upgrade

SIS b Do 1 dovoob)
= gl Bhenet (169254 127,103
Q) ko

S % UrkowefM)-frmeare ¥3.30 100
2 e

Devicn Dot | Wes Corfprton | Tt Corfiurmton

1 Address: 92412736 pert 99 @ Daconnect ¢ Clewe

Software version ¥3.3.0.16C (131217) XPTEXE
Preas Encer for Setup Mode
Model: Device Sexver Pluse! (Firmware Code:Vd)

saavua/TCP o KTU Bridge Serup
1) Network/IP Setving:

163.254.127.26
169.254.127.1
28%.283.258.0

Modbus/RTU, Save () attached
s600,8,%, 1, R5485

.+ 00502
Modbus/TCP neader

Disabled (Id=0 auto-napped to 1)

Yes (recurn 00AN and 00B)

Chax, Message Timecsr 00050msec, 050COmses

5) Presec Automated Scan T

D)efault settings, S)ave, Q)uit without save
seiect o oz pazameter set (1..5) to change:

2

d Device (1-Siave Z-daster) (1) 7 1
Prozocol (1eMadbus/RTU 2wMedbus/ASCIZ) (2) 7|
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6.7 As shown in fig 6.7.1, enter (9600, 8, N, 2) to imply “Baud rate = 9600, Databit = 8, Parity = None, Stop bit =
2”.

e Gdt Yew Dowce Jook ey
Evasch ) Jotnte (@ s 9. B epus,
il Drvcn G [V bt Tt Crtp e

Do 1 devcat)
o T lniortend Phdies OIAIZN  per 9 @ Duconeed ¢ O

T i benedIO0 fevwae 113015
2w

19600,8,3,1) 9600,8,%,2

Fig 6.7.1

6.8 As shown in fig 6.8.1, enter ‘S’ or ‘s’ to save the changes. Then click “Connect” to verify the changes.

Ble Gt Vew Deice Tooks bel

<5 menr e 1330 16
Zwnous

Fig 6.8.1
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6.9 As shown in fig 6.9.1, verify the communication settings as “Baud rate = 9600, Databit = 8, Parity = None,

Stop bit = 2”.

File Edit View
Jsearch Q) Exclude 4 Assign P €8 Upgrade

Device Tools Help

(=48, Lantronix Devices - 1 devicels)
=g Ethemet (169.254.127.100)
=3 Unknown
-4 Unknown(YM) -fimware v3.3.0.1GC
L 168.254.127.88

Devios Deais | Web Carfiguration | Teinet Canfiguration |

IP Address: 169.254.127.86 Port: 9999 ﬂ_Dls:onnEd & Clear

Modbus/TCP to RIU Bridge

MAC address 0080A39299B9

Software version ¥3.3.0.1GC (131217) XPTEXE
Press Enter for Setup Mode

Model: Device Server Plus+! (Firmware Code:¥M)

Modbus/TCP to RIU Bridge Setup
1) Network/IP Settings:

IP AdATESS ..uvuvvrnnsnnains 169.254.127.86
Default Gateway .. 169.254.127.1
Hetmask .......... . 255.255.255.0
2) Serial & Mode Settings
Protocol .......e. . Modbus/RTU, Slave (gf attached

Serial Interface ........... 9600, 8, §, 2, RS485
3) Modem/Configurable Pin Sectings:

cp1 RS485 Output Enable
CP2 ...... GPIO (In)
CP3 ...... GPIO (In)

4) hdvanced Modbus Protocol settings:
Modbus/TCP POTt ............ 00502

Slave Rddr/Unit Id Source ..
Modbus Serial Broadcasts ...
MB/TCP Exception Codes .
Char, Message Timeout

5) Preset Automated Scan Tabl

Modbus/TCP header

Disabled (Id=0 auto-mapped to 1)
Yes (return Q0RH and 0OBH)
00050msec, 05000msec

7) Security
SR ccocorororocs
SNMP Commun:
Telnet Setup .
Telnet Debug
TFIP Download
Port 77FEh .
Web Server
Web Setup

. Enabled
public
Enabled
Enabled
Enabled
Enabled
Enabled
Enabled
Disabled
Disabled

D)efault settings, S)ave, Q)uit without save
Select Command or parameter set (1..5) to change:

10051-CCC Setup Procedure
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6.10 In file menu, press ‘F4” or click “Tools > Ping ...”.

Ble fde  Yew Qevice | Tooks | Help
) sewch D xciude QA Binge
T Larworse Dvvices - 1 dov Becover Frmware 1 | Cohgumien Teiet Corfiurmtin
ot  Cortgmor
‘D Mowalcd Qptions B4.127.06 ot 900 & Disconnect ¢ Clew
< Ui ez o W10 Bridge
=W Lesgune 0080A3929989
Suppoted Reicesemrs.. fyion v3.3.0.46¢ (131247) XPTEXE
Product information Base.
for Setup Mode
odais Davice Swrver Pluse! (Firwware Codeit)
Modbus/TCP 0 RTU Bridge Setup
1) Networ cxin
)
n
5) Praser Autcmated Soun Tab
7 Securiy
00
D)efault settings, 5)ave, Q)uLt Without save
Select Command or paramster set (1..5) to changel
| UL

6.11 Enter the IP address (e.g.

Fig 6.10.1

169.254.127.86 ) of the converter, then click “Ping”.

| | Clear Status

10051-CCC Setup Procedure
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6.12 If the converter responses, it will display 4 lines of message as shown in Fig 6.12.1

IP Address:
169.254.127.86 |

Ping | |ClearStatu5

Status:

Reply from 169.254 127 86: bytes=32 time=0ms
Reply from 169.254.127 86 bytes=32 time=0ms
Reply from 165.254.127 86: bytes=32 time=0ms
Reply from 169.254.127 86 bytes=32 time=0ms

Fig 6.12.1
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7. Verify Connectivity with Slave Device

This session assumes that user had already verified the communication with slave device using USB-to-serial

cable.

7.1 Open Modscan software. In the file menu, click “Connection > Connect”.

MODBUS Point Type

[Number of Polls: 0
lid )

01: COIL STATUS

10051-CCC Setup Procedure

c

Reset Cirs.

Fig7.1.1

AN 10051_1 (rev A)
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7.2 In the “Connect Using” field

DS elcl EET sitle
S@ng L]

of “Connection Details” page, select “Remote Modbus TCP Server”.

Device ld: | 1 |

-

MODBUS Point Type
Length: 100 | [o1: con sTatus -

[Famote TELNET Sarver
Agies

IRAS PPPoE Line
WAN Mesger 2TF)
IR

Fig7.2.1

7.3 Enter IP address of the Modbus TCP Converter. Leave Service Port (502) unchanged. Then click “OK”

10051-CCC Setup Procedure

Connect Using
IF\smuts modbusTCF Server j
IP Address: |158.254.12? &8
Service Port:|502
Configuration
Hardweare Flow Control
Baud Rate:  |19200 hud
™ walt for DSR from slave
“iord Length: |8 e Delay [0 ms after RTS before
transmitting first character
Pariy:  [MONE s ™ walt for TS from slave
Delay |0 s after last character
Stop Bits: |1 | before releasing RTS
Protocal Selections
.
Fig7.3.1
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7.4 Enter the fields of interest (Address: 0001, Length: 100, Device Id: 1, Modbus Point Type: 03 — Holding
Register). Verify “Number of Polls” and “Valid Slave Responses” match to denote Modbus TCP

Eile  Connection

communication is successful.

Setup View Window Help

D@ =& BES S/2)w

o5 0 oo s

= ModScal |[E=RE=R =)
Device Id: lII
Address: - Number of Polls: 129
MODBUS Point Type Valid Slave Responses: 129

Length:  [100 [03: HOLDING REGISTER =] eTREE

4000L: <DDL92» 40013 <00593> 40025 <00193: 40037: <0L800> 40049, <000Z5> 40061, <00000> 40073: <00201> 40085: <00000> 40097, <00002>

40002 <0000Z> 40014. <00000> 40026. <0O0000> 40038. <000L0: 40050, <00040> 40062, <00000> 40074: <0000Q: 40086. <00000> 40098, <0001S>

400031 <0D12B> 40015: <00599> 40027: <0000D> 40039: <00000> 40051 <00002> 40063 <05122> 40075: <0D0000> 40087: <00000> 40099 <000D3>

40004: <D1283> 40016: <00DDD> 40028: <00192> 40040: <00300> 40052 <00000> 4D064: <00000> 4D076: <00000> 40088: <00000> 40100: <00000>

40005 <DODOO> 40017. <00D63> 40029, <O0000: 40041. <0O090: 40053, <00047> 4D0EE. <00000> 4D077: <00009: 40089. <00000>

40006 <00L20s 40016. <00DDD> 40030, <O0000> 40042 <QO020> 40054, <00000> 40066, <00000> 40078: <0O00Qs 40030: <00000>

10007: <00000> 40019: <00023 40031: <33338> 40043: <00090> 40055: <00033> 40067: <00000> 40079: <00000> 40091: <00090>

40008 <DDDDD> 40020: <64130> 40032: <33338> 40044: <00020> 40056 <00000> 40068 <00008> 4D0BD: <00000> 40092: <00000>

40009 <DD120> 40021 <00120> 40033 <01000> 40045 <00000> 40057 <00000> 4D0E%. <O1782> 4DD81. <00000> 40093. <00000>

40010 <DDDO0s 4002Z. <00064> 40034, <OO00S: 40046. <OO095: 40058, <00000> 40070, <00000> 40082: <00000> 40094: <00010>

40011: <00000: 40023: <00000> 40035: <00010> 40047: <00000: 40059: <00000> 40071: <00000> 4008%3: <00000: 40095: ¢00023>

40012 <DD0OD> 40024: <00132> 40036: <0000D> 40048° <00000> 40060 <00000> 40072 <00062> 400B4: <00000> 400960 <00010>

< >

For Help, press F1

Polls: 123 Resps: 129 a

Fig7.4.1
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8. Change IP address

8.1 To change the IP address and Subnet Mask of the Modbus TCP Converter, click “Device > Assign IP
Address”.

File Edit View | Device | Toals Help

4 search Q) Excludy Search 5
a Qlamm D“ri; Add Device.. 5 UssrMame  UserGmup [P Adcees Hardware Adcbess  Statue
Sl Ethemet Assign IP Address... L E—— s =
(=] Uﬂm‘

169.254127.86  0DB0-AT 9298 Orine
Upgrade

Exclude Devices Form Search Results..

|

8.2 Select “Assign a specific IP address”, then click Next.

Assignment Method

Would you ike to specify the IP address or should the unit get its
settings from a server out an the network?

() Obtain an IP address automatically

(®) Assign a specific IP address

TCP/IP Tutorial

<Back Next> | | cCancel | [ Hep

Fig 8.2.1
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8.3 Enter the IP address, Subnet Mask, and Default gateway, then click Next.

8.4 Click “Assign”.

10051-CCC Setup Procedure

IP Settings

Please fill in the IP address, subnet, and gateway to assign the device.
The subnet will befilled in automatically as you type, but please verify
it for accuracy. Incorrect values in any of the below fields can make it
impossible for your device to communicate, and can cause network
disruption.

Default gateway | 169.254,127.1

| <Back || Mext> || Cancel || Hep
Fig 8.3.1

Assignment

Clickthe Assign button to complete the IP address assignment.

< Back Finish Help

Fig 8.4.1
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8.5 Click “Finish”.

Assignment

Click the Assign buttonto complete the IP address assignment.

Progress of task:

Completed successfully.

| Finish || Cancel || Help

Fig 8.5.1

8.6 Note that every time the IP address is changed, the converter will default the serial communication
settings to (9600, 8, N, 1). To change the com settings different from the converter default, repeat session 6.
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A. Setup Static IP Address

Below are the steps to setup static IP address in the computer so that one can use a cross over RJ45 cable to
communicate directly with the Modbus TCP Converter.

Al. Open network page and select Ethernet connection.

A2. As shown in Fig A2.1, click “Properties”.

10051-CCC Setup Procedure

General

Connection
IPv4 Connectivity:
IPvE Connectivity:
Media State:
Duration:

Speed:

No network access
Mo network access
Enabled

00:08: 16

10.0 Mbps

Sent — k! ——  Received

=4

Packets: 1,409 |

0

|®Eroperties || @Qisable || Diagnose |

Cloze

Fig A2.1

AN 10051_1 (rev A)
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A3. Highlight “Internet Protocol Version 4 (TCP/IPv4), then click “Properties”.

il x

Networking | Sharing

Connect using
¥ Reattek PCle GBE Famiy Controller

This connection uses the following items

-4 GEIP PROFINET DCP ”
[ - Microsoft Network Adapter Multiplexor Protocol

-4- Microsoft LLDP Protocol Driver

-4 Link-Layer Topology Discovery Mapper /0 Diiver

-4- Link-Layer Topology Discovery Responder

[ -+ Intemet Protocol Version & (TCP/IPvE)

¥ et Protocal Version 4 (TCP/IPv4) v
< >

el
Description

Transmission Cortrol Protocol/Intemet Protocol. The default
wide area network protocol that provides communication
across diverse interconnected networks,

Fig A3.1

A4. Set the IP address of the computer as “1.1.1.100” (as shown in Fig A4.1) since we don’t know the IP address of
the Modbus TCP Converter at first . Then click “Ok”, “Ok”, and “Close” to exit the “Ethernet Status” page.

10051-CCC Setup Procedure

General

YYou can get IP settings assigned automatically if your network supports
this capability. Othernise, you need to ask your network administrator
for the appropriate IP settings.

(©) Obtain an TP address automaticaly

(®) Use the following IP address:

IP address: 1.1.1 .10
Subnet mask: 255,255,255 . 0
Default gateway: 1.1.1.1

Obtain DNS server address automatically
(®) Use the following DINS server addresses:

Breferred DNS server:

|

Alternate DNS server:

[ validate settings upon exit

Fig A4.1
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